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1.Introduction 

Axis Studio not only allows the export of motion capture data but also be able to stream motion 

capture data in real-time to third party applications, making the data available to drive characters 

in animation. 

Axis studio act as a server on a network and stream motion capture data live to a client PC running 

a client application. In this document specifically go through the process about streaming data to 

UE4 from Axis Studio with the NeuronLiveLink Plugin. 

1.1 Features  

• Support UE4 version 4.25.0 

• Support to receive and process the props (PWR-tracker) motion capture data (refer to 

our VPS project) 

• Support to drive a skeleton that is not using T-pose based model, such as A-pose 

based model. 

• Support to receive and process the displacement data from Axis Studio 

• Add Neuron Live Link Content which including: 

◆ MaximoLiveLinkRemapAsset (Select PN/PN Pro Skeleton in Axis Studio) 

◆ StudioLiveLinkRemapAsset (Select PNS Skeleton in Axis Studio) 

◆ Robot (Notiom sample FBX skeletal mesh and sample Animation Blueprint) 

• Modify Remote address to 127.0.0.1 as default in the Live Link Streaming Manager. 

1.2 Known issues 

• Error may occur when run executable after packaging. 

1.4 About  

1. Supported Development Platforms: Win64 

2. Supported UE4 Version: 4.25.0 

 

 

  



                  

 3 / 32                                           Live Link Plugin for Axis  

 

2.Installation 

1. Create a Plugins folder in your Unreal Engine Project  

2. Extract NeuronLiveLink zip file to the Plugins folder you created. 

 

  



                  

 4 / 32                                           Live Link Plugin for Axis  

 

3.UE4 Project Setup  

1. Inside your UE4 project, from the Menu Bar under Edit, select Plugins. 

 

2. Under the Animation section, click Enabled for Live Link and under the Installed 

section, click Enabled for NeuronLiveLink then restart the Editor. 

 

 

3. In the Content Browser Click View Option and enable Show Plugin Content. 
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Note: This will enable the Live Link Plugin, which can be used to connect to external Digital 

Content Creation (DCC) tools. In order for your DCC tool to connect to UE4, you will need to 

enable the corresponding plugin. In this section, we are establishing a connection with Axis 

Studio. 
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4.Quick Start 

1. Open Axis Studio and Replay a file. 

 

2. Go to Menu >Settings >BVH Broadcasting and Enable BVH-Edit 
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3. Open the Live Link Streaming Manager and Add Axis Neuron Live source. 

 

4. Drag PNS Animation Blueprint into the viewport. 

 

5. Click play button to see your animation. 
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5.Import Skeletal Mesh.  

1. In the Content Browser Click Import button. 

 

2. Locate and select the FBX file you want to import. 

 

3. Click Open to begin importing the mesh file to your project. 

4. In the FBX Import Options dialog box, choose the appropriate settings, making sure 

that the Skeletal Mesh option is enabled. 

Note: If no existing Skeleton is selected, a new one will be created from the Skeletal Mesh 

being imported. The new Skeleton's name will be that of the Skeletal Mesh 

with Skeleton appended. 

 

5. Click Import or Import All to import the mesh to your project and select the FBX file 
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containing the character you wish to import. 

 
Note:  this Tutorial we use Axis standard model Model_PNStudio_UE4.fbx, you can 

download here.https://support.neuronmocap.com/hc/en-us/articles/360006160713-Setup-

For-Unreal-Engine-Plugin-for-Axis-Software- 

 

The resulting mesh is displayed in the Content Browser if the process was successful. 

 

  

https://support.neuronmocap.com/hc/en-us/articles/360006160713-Setup-For-Unreal-Engine-Plugin-for-Axis-Software-
https://support.neuronmocap.com/hc/en-us/articles/360006160713-Setup-For-Unreal-Engine-Plugin-for-Axis-Software-
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6.Axis Studio Setup 

1. Launch Axis Studio and open a project 

2. Go to Menu >Settings  

 

3. Navigate to BVH Broadcasting, enable BVH-Edit (or BVH-Capture)  

 

Note: Enable BVH-Edit if you want to stream motion capture data from Editing and Enable 

BVH-Capture from Capturing viewport. Set network and other appropriate options, then 

click OK. 
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4. Connect PNS device or playback motion data. 
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7.Live Link Plugin Setup. 

1. With Axis Studio running in the background, inside UE4 from the File Menu 

under Window, select Live Link.  

 

Note: This will open the Live Link Streaming Manager, which will enable you to connect to the 

running instance of Motion Builder.  

2. Click the + Source button, then under Axis Neuron Live, set network and click Ok.  
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Note: Disable Is UDP if you use TCP protocol. The Streaming Manager will update to show the  

3. Connected Source Type and Subjects being streamed to UE4.  
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8.Manipulate Animation Blueprint Asset. 

1. Right-click on the Skeletal Mesh you want the Animation Blueprint to target and 

click Create > Amin Assets > Amin Blueprint. 

 

2. The Animation Blueprint is created in the same folder as the target Skeletal Mesh 

asset, with the name ready to be edited. 

 

Note: If you want to, type a new name for the new Animation Blueprint and press Enter. 

Double click the Animation Blueprint you just created.  

3. Right-click in AnimGraph to create Live Link Pose. 

 

4. Connect Live Link Pose node to Output pose node. 
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5. Click Live Link subject Name dropdown button and select subject. 

 

6. Click Live Link Pose and the Details panel displays. 

 

7. Click Retarget Asset dropdown button and select NeuronLiveLinkRemapAsset. 
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8. Click Compile and save. 

 

After all those setups correctly and you can preview the animation in the viewport now. 

 

  



                  

 17 / 32                                           Live Link Plugin for Axis  

 

9.Projects Packaging  

9.1 Implement animation driven. 

1. On the Main Toolbar click the Blueprints button then select Open Level Blueprint. 

 

Note: Event Graph displays and with default nodes Event BeginPlay and Event Tick. 

 

2. Move Mouse over + button, click +Variable button to add Variable in My Blueprint 

panel and type a new name for the Variable in the Details panel and press Enter. 

 

3. Set Variable Type as Structure (Live Link Source Handle) in the Details Panel. 
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4. Create Neuron Live Link Source at runtime and connect it to Event BeginPlay in 

Event Graph. 

 

 

5. Create Set node and connect to Create Neuron Live Link Source at runtime. 
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6. Right-Click to create Event EndPlay. 

 

7. Create Remove Source and connect to Event EndPlay node. 
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8. Create Get node and connect to Remove Source node.  

 

9. Go back to Live Link Window to get Connection String. 

 

10. Select Axis Studio source and Click Show Advanced in Settings panel. 
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Note: Connect string and Factory will display in the Settings panel. 

Copy Connection String in settings panel and paste it into Create Neuron Live Link Source at 

runtime node in Event Graph. 

 

 

11. Click Compile and Save. 
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If you finish all setup above your character will be driven by the motion data from Axis 

studio when you hit the play button. 

9.2 Animation setup 

1. In the Content Browser, locate the Skeletal Mesh you want to add to the map as 

a Skeletal Mesh Actor. 

2. Place it into the viewport.  

 

3. Set Animation Class.  
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4. Click play button to see your animation. 

5. Click Save Current and type a name for it. 

Note: You can also drag your AnimationBlueprint into the viewport directely.  
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9.3 Game default map setup 
Before packaging your game, you will first need to set a Game Default Map, which will load 

when your packaged game starts. If you do not set a map and are using a blank project, you will 

only see a black screen when the packaged game starts. If you have used one of the template maps, 

like the First-Person template or Third Person template, the starting map will be loaded. 

1. Click on Edit > Project Settings > Maps & Modes in the Editor's main 

menu. 

 

2. Click on File > Package Project > [PlatformName] in the Editor's main menu. 
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You will be presented with a dialog for selecting the target directory. If packaging completes 

successfully, this directory will then contain the packaged project. 
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10.Remapping Bone Name  

Your Skeletal Mesh may use different skeleton with Axis standard skeleton. In this situation you 

cannot apply NeuronLiveLinkRemapAsset to LiveLinkPose for your animation need to create your 

own retarget asset for your s specific skeletal mesh. In this section we go through the setup process 

to create custom retarget asset.  

 

1. In the Content Browser, click the Add New button. 

 

2. Select Blueprint Class from the Create Basic Asset section of the dropdown 

menu. 

\ 

3. Search NeuronLiveLinkRemapAsset and Click Select button. 
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Note: If you want you can rename it in the Content Browser. 

Double click to open it. 

4. Move Mouse over + button (Function), click Override dropdown button to select Get  

remapped Bone Name in My Blueprint panel.  

 

 

5. Delete Parent: Get Remapped Bone Name node and create Switch on Name. 

6. Add all the bones name of Axis and SK_Mannequin, manually assign the 



                  

 28 / 32                                           Live Link Plugin for Axis  

 

corresponding Bone.  

 

7. Click Compile and Save button. 
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11.Manage Retarget Base Pose   

There may be instances where you want to retarget animations to a Skeleton that is not quite using 

the same base pose as your Source Skeleton. 

For example, the base pose of SK_Mannequin_Skeleton is A -pose but you want to use animation 

from Axis Studio which using T -pose as reference/base pose. we may encounter animation issues. 

In this section we go through how to solve this problem. 

3. Inside the Content Browser, double-click SK_Mannequin_Skeleton. 

 

4. Inside the Skeleton Editor, from the Toolbar click the Retarget Source 

Manager button.  

 

5. Edit base pose from A-pose to T-pose (select bones in our character and rotate 

them).  

 

6. Click Modify Pose button. 
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7. In context menu, select Use Current Pose. 

 

8. Inside the Skeleton Editor, from the Toolbar click the Create Asset and 

select Create Animation at current pose. 

 

9. Select path and Click OK button. 

You will see SK_Mannequin_Skeleton_Sequence asset is created in Asset Browser and 

automatically be open. 



                  

 31 / 32                                           Live Link Plugin for Axis  

 

 

10. Add the SK_Mannequin_Skeleton_Sequence under Asset Browser into Animgraph of 

your Animation Blueprint and connect it to Live Link Pose node. 

 

11. Click Compile and Save.  
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12.Examples 

11.1 Working with Maximo character 

1. Open your UE4 Project and Install NeuronLiveLink Plugin 

2. Run Axis Studio and play a file or connect device 

3. Select Perception Neuron Studio Skeleton in BVH Broadcasting 

4. Import Maximo character into your UE4 project  

5. Add Axis Neuron Live source in in the Live Link Streaming Manager  

6. Create Animation Blueprint based on Maximo Skeletal Mesh asset  

7. Open Animation Blueprint  

8. Add Live Link Pose node and connect to Output Pose node 

9. Select MaximoLiveLinkRemapAsset as Retarget Asset. 

10. Select Live Link Subject Name  

11. Click Compile and Save 

 


